FAQ Search
Memberlist Usergroups
Profile
  Forum Statistics Register
 Log in to check your private messages
Log in to check your private messages
Moonpod Homepage Starscape Information Mr. Robot Information Free Game Downloads Starscape Highscore Table
Available updates (v1.05)
Post new topic   Reply to topic    Discussion Pod Forum Index -> Mr.Robot View previous topic :: View next topic  
 Author
Message
Poo Bear
Pod Team
Pod Team


Joined: 14 Oct 2002
Posts: 4121
Location: Sheffield, UK



PostPosted: Tue Apr 24, 2007 9:22 am    Post subject: Available updates (v1.05) Reply with quote

New version ready so hit your in game update button to get it.

The main downloads have been updated, so if you downloaded the demo after this date you have the latest version anyway. You can double check by hitting update in game.


1. saves referring to user adventures that have been deleted causes game crash.
2. cannot download user adventures.
3. old user adventures that need update don't always register properly and therefore don't ever get updated.
4. unicode support for foreign language windows installs.
5. pressing escape and fire1 can sometimes get the PDA in a confused state.
6. rare message log error can crash the game.
7. another instance of having multiple blue keys, this one causes a crash when you meet Samson.


Last edited by Poo Bear on Wed Sep 12, 2007 1:12 pm; edited 1 time in total
Back to top
View user's profile Visit poster's website
HEL 9000



Joined: 26 Apr 2007
Posts: 36
Location: Behind you...



PostPosted: Thu Apr 26, 2007 4:42 pm    Post subject: Reply with quote

I still cant download user adventures even after getting patch v1.05


errr... well... with the exception of the user adventure "Fred"
Back to top
View user's profile Visit poster's website MSN Messenger
Fost
Pod Team
Pod Team


Joined: 14 Oct 2002
Posts: 3734



PostPosted: Thu Apr 26, 2007 4:53 pm    Post subject: Reply with quote

Do you get an error? Where does it go wrong?
Back to top
View user's profile Visit poster's website
Slyh



Joined: 25 Nov 2004
Posts: 480
Location: Karlsruhe, Germany



PostPosted: Thu Apr 26, 2007 5:41 pm    Post subject: Reply with quote

I have a problem running SaveHuey: The game crashed after I created a new game for SaveHuey. After a restart of Mr.Robot the game now appears in the profile list, but Mr.Robot still crashes when I try to start it. Creating another SaveHuey game inside another still empty profile did not help.

I just downloaded the game. The content of directory 11 in directory 'unofficial' looks fine as far as I can tell. Other games (for example ZonaRosa) work fine.

MPErrorStream.html is empty.

EDIT: Same problem for DrBrainRedux which I just downloaded. It seems as if DrBrainRedux does not even appear in the 'unofficial'-directory.

Is it save to delete directories there? Number 14 seems to be corrupted.
Back to top
View user's profile
Blizgerg



Joined: 09 Jan 2005
Posts: 155
Location: The Planet Stinky Socks



PostPosted: Thu Apr 26, 2007 5:54 pm    Post subject: Reply with quote

Slyh wrote:
Is it save to delete directories there? Number 14 seems to be corrupted.


AFAIK yes. I personally wiped the unofficial directory (after backing it up) after I updated to v1.05 and then redownloaded everything.
Back to top
View user's profile
Fost
Pod Team
Pod Team


Joined: 14 Oct 2002
Posts: 3734



PostPosted: Thu Apr 26, 2007 5:55 pm    Post subject: Reply with quote

Slyh wrote:
I have a problem running SaveHuey:

Slyh - I'm guessing your XP username contains non-ascii? If so, that's a problem we know about and Mark is looking at. I'm not sure it's related to HEL 9000's issue.

Slyh wrote:
Is it save to delete directories there? Number 14 seems to be corrupted.

Yesm you cn delete any of the user adventure folders and it should be ok.
Back to top
View user's profile Visit poster's website
Slyh



Joined: 25 Nov 2004
Posts: 480
Location: Karlsruhe, Germany



PostPosted: Thu Apr 26, 2007 6:06 pm    Post subject: Reply with quote

Fost wrote:

Slyh - I'm guessing your XP username contains non-ascii? If so, that's a problem we know about and Mark is looking at.


No. My XP username is 'slyh' and my computer's name is 'tobias'. The path to Mr.Robot does not contain non-ascii, either. Strange.
I will delete some of the folders and try again.

EDIT: I deleted 'unofficial' and downloaded SaveHuey again. Still no luck.
Back to top
View user's profile
Rup



Joined: 19 May 2003
Posts: 363
Location: London, UK



PostPosted: Thu Apr 26, 2007 6:16 pm    Post subject: Reply with quote

That happened to me too - the game crashed trying to start Save Huey. Sometimes I'd get an assert "unknown object type 275" or similar.

I fixed it by a fresh download and install of 1.05. I'd first tried cleaning out my My Documents/MrRobot but that didn't work. (I haven't yet tried putting my save games back with the working 1.05, though.)
Back to top
View user's profile
Fost
Pod Team
Pod Team


Joined: 14 Oct 2002
Posts: 3734



PostPosted: Thu Apr 26, 2007 9:27 pm    Post subject: Reply with quote

We do know of one issue BUT we can't understand how it would cause a problem: currently, the downloads directory isn't cleared when you download an adventure. If you upgrade, it then copies everything over the root of the game install dir. None of this still gets loaded though.

Maybe as Rup mentioned, try deleting everything in your install dir, then install again using the latest version. Maybe ... (I'm clutching at straws though).

Weird this - we can definitely recreate the unicode XP accounts issue, but not this. Before you delete it, could you have a look in your install dir and let me know what's in there.

-thanks!
Back to top
View user's profile Visit poster's website
Rup



Joined: 19 May 2003
Posts: 363
Location: London, UK



PostPosted: Thu Apr 26, 2007 10:34 pm    Post subject: Reply with quote

The update appears to be missing some changes that are in the v1.05 clean install: crucially objects.config definitions 275 and 276, cryogenics lift wall and lift wall top, and the two model and texture files for them. These are used in Save Huey hence the crash.

There's also missing changes to frontend\eidolon_diorama\scene.mdl and blackhole.str (change Polish to Russian) that are in a v1.05 MrRobot.000 but not the v1.05 upgrade MrRobot.001.

I'm updating from a v1.00 MrRobot.000. It'd make sense if these changes were in the v1.02 MrRobot.000 (I don't have a v1.02 installer to hand to check), so applying the v1.05 patch to a v1.02 install would work fine, but they weren't in the v1.02 upgrade MrRobot.001 either.
Back to top
View user's profile
Fost
Pod Team
Pod Team


Joined: 14 Oct 2002
Posts: 3734



PostPosted: Thu Apr 26, 2007 10:46 pm    Post subject: Reply with quote

Hmm, they should be in the .001 file. They wer in the 102 patch Sad

Thanks tons anyway - that's narrowed down what's going on with some people. If we fix this and fix the unicode user account issue, I think we should be back on track Smile
Back to top
View user's profile Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Discussion Pod Forum Index -> Mr.Robot All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group